Mitel incident

CloudLink Daemon - Newly setup connections for the Daemon get 'Couldn't create inventory report' error

Notice Resolved View vendor source →

Mitel experienced a notice incident on August 20, 2026 affecting CloudLink Accounts Portal, lasting 12d 21h. The incident has been resolved; the full update timeline is below.

Started
Aug 20, 2026, 02:34 PM UTC
Resolved
Sep 02, 2026, 12:30 PM UTC
Duration
12d 21h
Detected by Pingoru
Aug 20, 2026, 02:34 PM UTC

Affected components

CloudLink Accounts Portal

Update timeline

  1. identified Aug 20, 2026, 02:34 PM UTC

    This issue affects any MSL hosted Daemon that has an MBG as part of the manifest(stand-alone MBG, MiCollab, SMBC, SVI server). Any newly created connections on MSL 12.2 or upgrades to 12.2 MSL will get the 'Couldn't create inventory report' error. A fix is being tested in our Dev cloud. This will be update when the fix is pushed to production.

  2. monitoring Aug 25, 2026, 02:06 PM UTC

    The fix has been pushed to production as part of CloudLink Daemon version 1.9.15. Manually updating to this release from the Daemon page in server manager or waiting for the next scheduled release should fix the issue.

  3. resolved Sep 02, 2026, 12:30 PM UTC

    This incident has been confirmed resolved.